iSTAR Ultra G2 issue

We have a Ultra g2 that we upgraded the firmware on, 6.92 and now we cannot Log into the panel. I can ping but cannot access via web page. (tried all three Chrome, Edge, And Firefox), also plugged it into switch, to get a dhcp. once that got the address I could ping it, but again no login.
I wasn’t the one that did the upgrade, but it was done through chrome, directly plugged into port 2.
is there any input of a fix ? I have never seen this before, my guess is the wrong firmware got put into it, but cannot confirm.

The Ultra’s only accept a .i8 firmware file via the webpage so it is not possible to load an incorrect version.

If your getting rejected at the login screen, ensure a new password was not setup by the person who performed the firmware update. 1st time you login to the Ultra use the default login, it requires a new password be setup immediately. Start by trying a factory default. This usually helps resolve most issues.

Thank you for the reply.
The issue is, i cannot login via the web browser. I cannot even get to the Login screen, the web page(S) just time out.
I have tried to do the factory default a few times, so I am at a loss, I have done many firmware updates through web, and ccure as well as ICU, and have never seen this issue. This is why I took the panel to troubleshoot, and its got me stumped. :thinking:
is it possable that he put the Edge firmware, or is the panel smart enough to know that its the wrong one?
Thanks again,

The Edge G2 is .i7, and Ultra G2 is .i8

You can try a hard reset, set the rotary switch to D and press the switch on the back of the GCM, it’s in the upper left corner just below the screw post and a bit in from it.

1 Like

Thanks, for the reply,
I did try that, but tried it again, and no luck.


It sounds like something else may be using that IP address. Try disconnecting the panel from the network and see if you still get ping responses.

Kind Regards,

Chris Vanderbles, Master Certified Integrator
XSiV Technologies, LLC

Hey Chris,
The panel is not plugged into the network.
i can ping on nic two port, but cannot even get to the login screen in any of the 3 browsers i try, but my bench controller i can plug into and get in no problem.


It sounds like a IP conflict. If you get to the point where you can ping it from the same network, I’d run an ARP command from your workstation and see what MAC address is reporting back from the ping. I’m lazy, so I also include the “find” command in my output.

Step 1: Open command window and ping the IP address (make sure you get a response).
Step 2: use the following command, where x.x.x.x is the ip address you’re pinging:
arp -a | find “x.x.x.x”

That will use your workstation/laptop’s local Address Resolution Protocol table to return the MAC address of the IP that is responding to your pings. If it doesn’t start with a 00:50:F9, then it’s not a SWH device.

Kind Regards,

Chris Vanderbles, Master Certified Technician
XSiV Technologies, LLC

The panel is NOT on the network. its literally sitting on my bench, i plug my Laptop into port two on the G2 and ping the default . I can ping the address, but that’s as far as i get.
I have tried to default the panel, with the rotary switch and the reset button on the front, I’ve tried it also with the button on the rear.
I have done many firmware upgrades and never had this kind of issue.
I don’t know what the tec did wrong during his upgrade, but it is a simple process, so it has me confused.


Stupid question, but I have to ask… are you sure you’re putting in “https://” in front of the IP address and not just http? iStar Ultras and G2s do not respond on http at all.

1 Like

Is your laptop set to the same VLAN 192.168.1.x?

yes, thanks for the reply